Skip to content

在 Firefox 52.0 啟用 Java

2017 年 03 月 07 日,Firefox 釋出了最新的 52.0 版本。

其中,有一點很重大的改變:就是移除了 NPAPI (Netscape Plugin API)。簡單來講,如果網頁上,使用了 Java、Silverlight 或其他 NPAPI 技術,這些 NPAPI 外掛將不會發生作用。

對於多數使用者而言,這些外掛有沒有作用,影響可能不大,但若是 Java,影響就會比較大,通常在 Firefox 使用網路 ATM,都是利用 Java 做溝通,讓 Firefox 可以抓到晶片讀卡機,若 Java 無作用,也就代表我們無法使用網路 ATM,雖然換成 IE 一定沒什麼問題,但如果很堅持一定要用 Firefox,但又不能用 Java,那就會很冏了……

既然這個功能是 Firefox 52.0 才有的,也就代表只要我們使用比 52.0 更舊版本的 Firefox,就不會有一些困擾。

使用舊版本的確是一個解決方案,只是除非舊版本檔案有保留,否則若要找到官方舊版下載網址,就會比較麻煩一點。畢竟從非官方網站下載檔案,總感覺好像哪裡怪怪的。

其實除了使用舊版本之外,還可以安裝 Firefox ESR 版本。所謂 ESR 版本,原本主要是針對企業、組織……等環境使用的版本,原因是後期 Firefox 版本更新週期加快,可能會導致原本在使用的外掛或擴充套件與新版本不相容的情況,在某些環境,穩定性會比版本的新舊來得重要。

ESR 版本不會自動更新,也不會自動提醒更新,同時只有安全性的更新,不會有功能更新。

目前 Firefox 最新版本是 52.0.2,值得高興的是 Firefox ESR 版本也是 52.0.2,且 ESR 版本仍然可以使用 Java、Silverlight 這類的 NPAPI 外掛程式。因此如果不是那麼一定要用最新版本的 Firefox,反倒是可以試試 Firefox ESR 版本。

雖然 ESR 版本可以解決一些問題,但如果你喜歡擁有新功能、技術的 Firefox,那麼 ESR 版本就不適合你。

ESR 版本在 Firefox 比較不容易找到,但我們可以利用以下連結至官方下載頁面

https://www.mozilla.org/en-US/firefox/organizations/all/

選擇下載 ESR 版時,要注意一點,如果你選擇的是 64 位元版本,它只可使用 Adobe Flash 以及 Microsoft Sliverlight,換言之,若要使用 Java,則必須使用 32 位元的 ESR 版本。

原有的 Firefox 不用先行移除,直接下載並安裝 ESR 版本,安裝完成之後,書籤、Cookie、已儲存的帳號密號、設定值……等,都不會受到影響。

是不是使用 ESR 版本,可以從「About Firefox」中得知,ESR 版本,會特別在 Firefox 後面加上 ESR 字樣。

一般版本:

ESR 版本:

【其他資訊】

Published in問題筆記網路軟體

Be First to Comment

發表迴響

你的電子郵件位址並不會被公開。 必要欄位標記為 *